How to fix: svn: error: The subversion command line tools are no longer provided by Xcode

As I was getting ready to do my first svn check in today – I got an error that I had not seen yesterday:
“svn: error: The subversion command line tools are no longer provided by Xcode”

My operating system: macOS Catalina 10.15.3

Apple’s documentation on how to fix this: https://developer.apple.com/documentation/macos_release_notes/macos_catalina_10_15_release_notes

The solution:

  1. Open: The Terminal App
  2. Type: xcode-select –install
  3. After the install is complete – run your commands as you did before the error

About the Author...

Jennifer Zelazny

My name is Jennifer Zelazny and this site is a collection of my random thoughts and opinions. I am Penn Stater, WordPress developer, and a modern day explorer. I love exploring data, trends, and things that make the world a better place and sharing them here.

2 thoughts on “How to fix: svn: error: The subversion command line tools are no longer provided by Xcode”

  1. Hazhir

    Unfortunately this did not worked for me:

    xcode-select –install
    xcode-select: error: command line tools are already installed, use “Software Update” to install updates

Leave a Reply

Your email address will not be published.
*
*

This site uses Akismet to reduce spam. Learn how your comment data is processed.